内江特种设备检测:通达信自用公式集合(三)

来源:百度文库 编辑:思考网 时间:2019/11/22 00:03:18

即时资金流向:通达信 副图

轴:0,COLOR4B4B4B;
PJJ:=DMA((H + L + C * 2) / 4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
ZLL:=VOL / CAPITAL;
HSL1:=IF(ZLL > 10,10,ZLL);
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
流量:LLJX,COLORC875B7,NODRAW;
STICKLINE(流量 > 0,流量,0,2.3,0)COLOR0000FF;
STICKLINE(流量 < 0,流量,0,2.3,0),COLORFF4242;
流量基线:GJJ,COLOR00BBBB;
STICKLINE(HSL * 0.4 >= 0,HSL * 0.4 * 1.5,0,0,1)COLORYELLOW;
STICKLINE(HSL * 0.4 < 0,HSL * 0.4 * 1.5,0,0,1)COLORGREEN;
ZJLL:=REF(LLJX,1);
QZJJ:=(((LLJX - ZJLL) / ZJLL) * 100);
流量幅%:IF(((LLJX > 0) AND (ZJLL < 0)),ABS(QZJJ),IF((((LLJX < 0) AND (ZJLL < 0)) AND (LLJX < ZJLL)),(0 - QZJJ),QZJJ))COLORWHITE,NODRAW;
力度:HSL / 1000,COLOR9B37FF,NODRAW;
周流量:SUM(LLJX,5),COLORFFBFDF,NODRAW;
BB:=REF(周流量,1);
ZQZJJ:=(周流量-BB)/BB*100;
周幅%:IF(周流量>0 AND BB<0,ABS(ZQZJJ),IF(周流量<0 AND BB<0 AND 周流量
如图:
 

海风:波段KDJ  通达信 副图

H5:=HHV(HIGH,5);
L5:=LLV(LOW,5);
H3:=SUM((C-L5),3);
L3:=SUM((H5-L5),3);
K:=EMA((C-L5)/(H5-L5)*100,4);
D:=EMA((H3/L3)*100,4);
J:=EMA((3*K-2*D),4);
BUY1:=CROSS(K,D) AND CROSS(J,D) AND D<30 AND D>REF(D,1);
SEL1:=FILTER(REF(J,1)>75 AND JSTICKLINE(J>D AND K>D,J,D,5,0),COLORRED;
STICKLINE(JD,J,D,8,0),COLORYELLOW;
STICKLINE(JSTICKLINE(KD,J,D,8,0),COLORCYAN;
STICKLINE(J>D AND K>D AND JREF(D,1) AND J>50,J,D,8,0),COLORCYAN;
STICKLINE(BUY1,10,D,3,0),COLORWHITE;
DRAWTEXT(BUY1,10,'低进'),COLORYELLOW;
STICKLINE(SEL1,90,J,3,0),COLORGREEN;
DRAWTEXT(SEL1,90,'小心顶'),COLORYELLOW;

公式用法:

    在出现黄柱或第一根红柱时,尾盘收盘价买入,以后以收盘价为准,只要柱体不变色就不出,变色就尾盘出货。严格操作,就算大盘如此暴跌情况下,抓住一个股做,还是能保持大赚小亏总体有赢利。

 

小护士 通达信 副图

QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:EMA(涨,4),LINETHICK1,COLORFFFF34;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;
空线:IF(CROSS(跌,80),70,100),COLORFF9900;
买1:EMA(跌,4),COLORWHITE;
买2:EMA(买1,4),COLORGREEN;
买M3:=EMA(买2,4);
买M4:=EMA(买M3,4);
STICKLINE(涨STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR0088FF;
DRAWICON(多线,30,1);
DRAWICON(CROSS(跌,80),70,2);
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;
DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;
VAR811:=SUMBARS(VOL,FINANCE(7)*100);
VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR883:=(CLOSE-VAR822)/VAR822*100;
VAR884:=HHV(VAR883,VAR811);
VAR885:=LLV(VAR883,VAR811);
VAR886:=(VAR883-VAR885)/(VAR884-VAR885)*100;
K:=SMA(VAR886,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA1:=MA(J,3);
STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0),COLORYELLOW;
DRAWTEXT(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,60,'考虑买进'),COLORFFFFFF;
VAR1:=MA(CLOSE,152);
VAR2:=MA(CLOSE,194);
VAR3:=VAR2+2*STD(CLOSE,170);
VAR4:=VAR1+2*STD(CLOSE,170);
顶:CLOSE>(VAR3)*13*10,COLORBLUE,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10;
VAR3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR3C:=SMA(VAR3B,3,1);
VAR3D:=SMA(VAR3C,3,1);
VAR3E:=SMA(VAR3D,3,1);
VAR3F:=CROSS(VAR3D,VAR3E) AND VAR3D<20;
VAR40:=CROSS(VAR3E,VAR3D) AND VAR3D>80;
VAR41:=5;
DRAWTEXT(CROSS(VAR41,NL),30,'★做底'),COLORWHITE;

 

波段KDJ  通达信 副图

H5:=HHV(HIGH,5);
L5:=LLV(LOW,5);
H3:=SUM((C-L5),3);
L3:=SUM((H5-L5),3);
K:=EMA((C-L5)/(H5-L5)*100,4);
D:=EMA((H3/L3)*100,4);
J:=EMA((3*K-2*D),4);
BUY1:=CROSS(K,D) AND CROSS(J,D) AND D<30 AND D>REF(D,1);
SEL1:=FILTER(REF(J,1)>75 AND JSTICKLINE(J>D AND K>D,J,D,5,0),COLORRED;
STICKLINE(JD,J,D,8,0),COLORYELLOW;
STICKLINE(JSTICKLINE(KD,J,D,8,0),COLORCYAN;
STICKLINE(J>D AND K>D AND JREF(D,1) AND J>50,J,D,8,0),COLORCYAN;
STICKLINE(BUY1,10,D,3,0),COLORWHITE;
DRAWTEXT(BUY1,10,'低进'),COLORYELLOW;
STICKLINE(SEL1,90,J,3,0),COLORGREEN;
DRAWTEXT(SEL1,90,'小心顶'),COLORYELLOW;

公式用法:

    在出现黄柱或第一根红柱时,尾盘收盘价买入,以后以收盘价为准,只要柱体不变色就不出,变色就尾盘出货。严格操作,就算大盘如此暴跌情况下,抓住一个股做,还是能保持大赚小亏总体有赢利。

 

机构 能量 分布合成 通达信 副图

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
主力能量柱:STICKLINE(主力能量,0,ABS(主力能量),2,0),COLORRED;大户能量:(大户-均量),NODRAW;
大户能量柱:STICKLINE(大户能量,ABS(主力能量),ABS(主力能量)+ABS(大户能量),2,0),COLORYELLOW;{中户持仓量}
中户能量:(中户-均量),NODRAW;
中户能量柱:STICKLINE(中户能量,ABS(主力能量)+ABS(大户能量),ABS(主力能量)+ABS(大户能量)+ABS(中户能量),2,0),COLORMAGENTA;{散户持仓量}
散户能量:(散户-均量),NODRAW;
散户能量柱:STICKLINE(散户能量,ABS(主力能量)+ABS(大户能量)+ABS(中户能量),ABS(主力能量)+ABS(大户能量)+ABS(中户能量)+ABS(散户能量),2,0),COLORGREEN;{主导力量}
A:=MAX(主力能量,大户能量);
B:=MAX(中户能量,散户能量);
主导力量:MAX(A,B);
DRAWTEXT(ISLASTBAR=1 AND 主力能量>=0,主力能量/2,'[主力增仓]'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND 主力能量<0,ABS(主力能量)/2,'[主力减仓]'),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1 AND 大户能量>=0,ABS(主力能量)/2+0.8,'[大户增仓]'),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1 AND 大户能量<0,ABS(主力能量)/2+0.8,'[大户减仓]'),COLOR38FF38;
DRAWTEXT(ISLASTBAR=1 AND 中户能量>=0,ABS(主力能量)/2+1.6,'[中户增仓]'),COLORFF60FF;
DRAWTEXT(ISLASTBAR=1 AND 中户能量<0,ABS(主力能量)/2+1.6,'[中户减仓]'),COLOR66FF66;
DRAWTEXT(ISLASTBAR=1 AND 散户能量>=0,ABS(主力能量)/2+2.3,'[散户增仓]'),COLORFF88FF;
DRAWTEXT(ISLASTBAR=1 AND 散户能量<0,ABS(主力能量)/2+2.3,'[散户减仓]'),COLOR88FF88;

 

信号 通达信 副图

 

VAR2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR3:=SMA(VAR2,5,1);
VAR4:=REF(VAR3,1);
VAR5:=SMA(VAR3,10,1);
VAR6:=(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52))*100;
VAR7:=MA(VAR6,5);
VAR8:=LLV(LOW,5)=LLV(LOW,120);
VAR9:=REF(CLOSE,1);
VARA:=SMA(MAX(CLOSE-VAR9,0),6,1)/SMA(ABS(CLOSE-VAR9),6,1)*100;
VARB:=SMA(MAX(CLOSE-VAR9,0),12,1)/SMA(ABS(CLOSE-VAR9),12,1)*100;
VARC:=(CLOSE+LOW+HIGH)/3;
VARD:=SUM((VARC-REF(LOW,1)-(HIGH-VARC))*VOL/100000/(HIGH-LOW),0);
VARE:=EMA(VARD,1);
VARF:=VARE; VAR10:=MA(VARE,12);
VAR11:=MA(VARE,26); VAR12:=(VARF-VAR10)*60;
VAR13:=IF(VAR12>0.05,VAR12,0);
VAR14:=IF(VAR13>50,50,VAR13);
VAR15:=CAPITAL/EMA(VOL,5)/30*1.1;
VAR16:=VAR15; VAR17:=EMA(COST(85),10);
VAR18:=EMA(COST(1),10);
VAR19:=EMA(CLOSE,10);
VAR1A:=(VAR19-VAR18)*100/(VAR17-VAR18);
VAR1B:=REF(VAR1A,1);
VAR1C:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;
VAR1D:=(INDEXC-REF(INDEXC,12))/REF(INDEXC,12)*100;
VAR1E:=EMA(VAR1C-VAR1D,4);
VAR1F:=EMA(VAR1D-VAR1C,4);
STICKLINE(VAR1E>0,0,-5,6,0),COLORBLUE;
STICKLINE(VAR8,-5,-10,6,0),COLORYELLOW;
VAR20:=MA(VAR1C,4);
VAR21:=MA(VAR1C,8);
VAR22:=REF(VAR20,1);
VAR23:=MA((VAR1A-REF(VAR1A,12))/REF(VAR1A,12)*100,4);
VAR24:=IF(VAR23<=-20,-20,VAR23);
VAR25:=IF(VAR24>=20,20,VAR24);
VAR26:=VAR25;
VAR27:=REF(VAR26,1);
VAR28:=REF(VAR26,5);
VAR29:=IF(CROSS(VAR14,VAR16),1,0);
VAR2A:=IF(VAR14VAR2B:=IF(VAR1E>VAR1F,5,-5);
VAR2C:=IF(VAR3>VAR5,5,-5);
VAR2D:=IF(VAR20>VAR21,6,-6);
VAR2E:=IF(VAR20>0 AND VAR20>VAR21,8,-8);
VAR2F:=IF(VAR26<0,-10,10);
VAR30:=IF(VAR20>VAR22,10,-10);
VAR31:=IF(VAR26>VAR27,5,0);
VAR32:=IF(VAR26VAR33:=IF(CLOSE>OPEN,3,-3);
走势:(VAR2A+VAR2B+VAR2C+VAR2D+VAR2E+VAR2F+VAR30+VAR31+VAR32+VAR33);
VAR34:=REF(CLOSE,2)*0.865;
VAR35:=REF(CLOSE,13)*0.772;
VAR36:=MIN(VAR34,VAR35);
VAR37:=100*VOL/CAPITAL;
VAR38:=MA(CLOSE,13);
VAR39:=CLOSE>0.899*REF(CLOSE,1) AND CLOSE<0.901*REF(CLOSE,1);
VAR3A:=EMA(WINNER(CLOSE)*100,5);
VAR3B:=EMA(WINNER(CLOSE)*100,30)-CAPITAL/EMA(VOL,30)/5;
VAR3C:=CAPITAL/EMA(VOL,5)/5;
VAR3D:=VAR3A;
VAR3E:=IF(VAR3D>0,0-VAR3D,0-VAR3D); VAR3F:=REF(VAR3D,1);
主力趋势: (VAR3B+50);
VAR40:=VAR3B+50; VAR41:=REF(VAR40,1); VAR42:=MA(CLOSE,5); VAR43:=MA(CLOSE,10); VAR44:=MA(CLOSE,30);
VAR45:=MA(CLOSE,12);
VAR46:=MA(CLOSE,26); VAR47:=REF(VAR45,1); VAR48:=REF(VAR46,1); VAR49:=(VAR45-VAR46)/VAR45*100; VAR4A:=ABS(VAR45-VAR47)/VAR45*100; VAR4B:=REF(VAR46,1); VAR4C:=REF(VAR4A,1);
VAR4D:=REF(VAR42,1); VAR4E:=REF(VAR43,1); VAR4F:=COUNT(CLOSE>REF(CLOSE,1),5)/5*100; VAR50:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100; VAR51:=SMA(VAR50,5,1);
VAR52:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR53:=SMA(VAR52,2,1);
VAR54:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30)*8;
VAR55:=REF(VAR51,1); VAR56:=REF(VAR53,1);
VAR57:=REF(VAR54,1); VAR58:=MA(VAR53,5);
VAR59:=MA(VAR53,12); VAR5A:=MA(VAR53,26);
VAR5B:=REF(VAR4F,1); VAR5C:=(VAR54-VAR57)/VAR54*100;
VAR5D:=SMA(VAR50,5,1); VAR5E:=REF(VAR5D,1); VAR5F:=SMA(VAR52,2,1);
VAR60:=REF(VAR5F,1); VAR61:=IF(CLOSE>OPEN,1,0);
VAR62:=IF(VAR42>VAR4D,1,0); VAR63:=IF(VAR43>VAR4E,1,0);
VAR64:=IF(VAR4A>VAR4C,1,0); VAR65:=IF(VAR53>VAR56,5,0);
VAR66:=IF(VAR55>VAR51,5,0); VAR67:=IF(VAR54>VAR57,2,0); VAR68:=IF(VAR49>2.25,10,0); VAR69:=IF(VAR53>60,6,0); VAR6A:=IF(VAR53>80,8,0); VAR6B:=IF(VAR53>VAR51,10,0); VAR6C:=IF(VAR53>VAR51,VAR59-VAR5A,0); VAR6D:=IF(VAR53>VAR51 AND VAR51<20,5,0); VAR6E:=IF(CLOSE>VAR45 AND VAR45>VAR46,5,0); VAR6F:=IF(VAR45>VAR46,5,0); VAR70:=IF(VAR46>VAR4B,5,0);
VAR71:=IF(VAR51<18,VAR58-VAR51,0);
VAR72:=IF(VAR51>VAR53 AND VAR51>50,8,0);
VAR73:=(VAR61+VAR62+VAR63+VAR64+VAR65+VAR66+VAR67+VAR68+VAR69+VAR6A+VAR6B+VAR6C+VAR6D+VAR6E+VAR6F+VAR70+VAR71-VAR72);
VAR74:=REF(VAR73,1); 多头: MA(VAR73,5); VAR75:=MA(VAR73,8); VAR76:=MA(VAR73,12); VAR77:=MA(VAR73,26); VAR78:=MA(VAR73,13); VAR79:=REF(VAR76,1); VAR7A:=REF(VAR76,2);
VAR7B:=IF(CROSS(VAR3,VAR5) AND VAR4<35 AND VAR7>50 AND VAR1A<25 AND VAR1A>VAR1B AND VAR41VARB AND VARB>VAR3 OR VARA>VAR3 AND VAR8),100,0);
VAR7C:=IF((CLOSE-VAR36)/CLOSE<0.1 AND VAR41VAR7D:=IF(CROSS(VAR3,VAR5) AND VAR8 AND VAR3<25 AND VAR1A<20 OR CROSS(VAR3,VAR5) AND VAR8 AND VAR3<40 AND VAR1A<10,100,0);
信号: IF(VAR7B=100 OR VAR7C=100 OR VAR7D=100,20,-50),COLORYELLOW;
STICKLINE(走势<0,0,走势,1,0),COLORGREEN;
STICKLINE(走势>0,走势,0,1,0),COLORRED;

 股海航帆 通达信 辅图VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=MA(VAR1,7);
VAR3:=VAR2-MA(VAR1,7/2)<0;
VAR4:=VAR2-MA(VAR1,7/2)>0;
VAR5:=BARSLAST(VAR3);
VAR6:=0-BARSLAST(VAR4);
VAR7:=IF(VAR3<=0,VAR5,VAR6);
上买下卖: (-1)*VAR7, VOLSTICK;
强弱分界: 0, CIRCLEDOT;
  动力线 通达信 副图 会用的慢慢研究下
N:=30;M:=13;LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSIF:=90-RSI1,COLOR33DD33;
A4:=((C-LLV(L,33))/(HHV(H,33)-LLV(L,33)))*67;
VAR22:=LLV(LOW,10);
VAR33:=HHV(HIGH,25);
动力线:EMA((CLOSE-VAR22)/(VAR33-VAR22)*4,4);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
PP101:=SMA(RSV,3,1);
PP102:=SMA(PP101,3,1);
PP103:=3*PP101-2*PP102;
STICKLINE(动力线>0 AND ISLASTBAR AND ((PP103>PP101 AND PP103PP101),20,80,0,1),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ISLASTBAR AND ((PP103>PP101 AND PP103PP101),20,35,2,1),COLORGRAY;{底部保持关注,灰色}
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ISLASTBAR AND ((PP103>PP101 AND PP103PP101),35,50,2,0),COLORYELLOW;{底部酌情买入,黄色}
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ISLASTBAR AND ((PP103>PP101 AND PP103PP101),50,65,2,0),COLORRED;{强势持仓段,红色}
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND ISLASTBAR AND  ((PP103>PP101 AND PP103PP101),65,72,2,0),COLORLIRED;{阶段卖出,粉红}
STICKLINE(动力线>=3.45 AND ISLASTBAR,72,80,2,0) AND PP103STICKLINE(PP103{以下显示在上方第二行}
STICKLINE(动力线>0 AND ((PP103>PP101 AND PP103PP101),95,94,1,0),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ((PP103>PP101 AND PP103PP101),95,92,3,0),COLORGRAY;{底部保持关注,灰色}
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ((PP103>PP101 AND PP103PP101),95,94,1,0),COLORYELLOW;{底部酌情买入,黄色}
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ((PP103>PP101 AND PP103PP101),95,94,1,0),COLORRED;{强势持仓段,红色}
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND  ((PP103>PP101 AND PP103PP101),95,92,3,0),COLORLIRED;{阶段卖出,粉红}
STICKLINE(动力线>=3.45,95,92,3,0) AND PP103STICKLINE(PP103VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势:IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2,0),COLORMAGENTA;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
强弱分界:=50,COLORFFFFCC;
底部:=0,COLOR00FFFF;
安全:=20,COLORFFAA66,LINETHICK1;
预警:=80,COLORFFAA66,LINETHICK1;
顶部:=100,COLORFFFF33;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
{DRAWTEXT(CROSS(价位线,0.3),20+4,'●买'),COLORRED;}
DRAWTEXT(CROSS(3.5,价位线),110-4,'●卖'),COLORWHITE;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
主力线:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORBLUE;
超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORBLUE;
VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR21:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=LLV(LOW,33);
VAR51:=EMA(IF(LOW<=VAR41,VAR31,0),3);
主力进场:IF(VAR51>REF(VAR51,1),VAR51,0),COLORRED,NODRAW;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLOR000055;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.6,0 ),COLOR000077;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0 ),COLOR000099;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.5,0 ),COLOR0000BB;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.9,0 ),COLOR0000DD;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0 ),COLOR0000FF;
洗盘:IF(VAR51STICKLINE(VAR51STICKLINE(VAR51STICKLINE(VAR51STICKLINE(VAR51STICKLINE(VAR51STICKLINE(VAR51VAR12:=3;
VAR28:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
{股价准备启动:IF(CROSS(VAR28,VAR11),100,0),COLORRED,LINETHICK2;}
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
大黑马:IF(ZDHM OR ZHM,50,0),COLORYELLOW,LINETHICK3;
动态底部:=EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3);
准备买入:=CROSS(C,TROUGH(CLOSE,N,1)*1.02);
低点:IF(动态底部 AND 准备买入,50,0),COLORWHITE,LINETHICK3;
RSV11:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
K:=SMA(RSV11,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
短线:=EMA(J,6),COLORRED;
浮筹:=MA(短线,28)*1,LINETHICK2,COLORGREEN;
空方:=MA(100*(HHV(HIGH,35)-CLOSE)/(HHV(HIGH,35)-LLV(LOW,35)),3),COLORYELLOW;
DRAWTEXT(CROSS(短线,浮筹) AND 短线<36,20+4,' 买'),COLORLIBLUE;
DRAWICON(CROSS(短线,浮筹) AND 短线<36,20+4,17),COLORBLUE, LINETHICK1;
DRAWTEXT(CROSS(浮筹,空方),浮筹,' 追'),COLORWHITE;
DRAWICON(CROSS(浮筹,空方),浮筹,16);
 最佳买入 通达信 副图

 

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0),STICK,COLORRED;
VAR1:=SMA(最佳买入选股,3,1);
VAR2:=SMA(VAR1,3,1),COLOR0000FF;
VAR3:=SMA(VAR2,3,1),COLOR00FFFF;
建仓买点:IF(CROSS(VAR2,VAR3) AND (VAR2<40),5,0* 10000),COLOR0000FF,LINETHICK2;
STICKLINE(建仓买点,0,2.5,8,0),COLORRED;
STICKLINE(建仓买点,0.45,4.0,2,0),COLORRED;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
最佳买入时机: IF(CROSS(J,3),1,0),STICK,COLORFFFF00;
STICKLINE(最佳买入时机,0,1,3,0),COLOR009999;
STICKLINE(最佳买入时机,0,1,2,0),COLOR00DDDD;
STICKLINE(最佳买入时机,0,1,1,0),COLOR00FFFF;
机构建仓: IF(最佳买入<5,-0.2,0),STICK,COLOR00FF00,LINETHICK1;
机构建仓日:STICKLINE(机构建仓,0,-0.2,3,0),COLOR00FF00,LINETHICK6;

超然:底部爆发 通达信 辅图

 

STICKLINE(18,100,0,5,0),COLORBLUE;
VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
底部爆发:VAR12,COLORWHITE;
STICKLINE(VAR12>0,0,VAR12,3,0),COLORWHITE;
STICKLINE(VAR12>0,0,VAR12,2,0),COLOR555555;
STICKLINE(VAR12>0,0,VAR12,1,0),COLORWHITE;
STICKLINE(VAR02>0,0,VAR02,5,0),COLOR3A7841;
海岸:VAR02,COLORGREEN;
浪花:VAR01,COLORCYAN;
STICKLINE(VAR05 AND COUNT(VAR05,5)=1,0,VAR12,4,0),COLORRED;
 五合一量能  通达信 副图 V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((CLOSE - HY1) * 10,2))*0.1;
操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,1,0),COLORRED;
减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,1,0), COLORRED;
反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),6,6+多空趋势,1,0),COLORGREEN;
寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),6,6+多空趋势,1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,6,6.3),'多空'),COLORBLUE;
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
大户能量:(大户-均量),NODRAW;
中户能量:(中户-均量),NODRAW;
散户能量:(散户-均量),NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,1), COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,1), COLORRED;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,1),COLORGREEN;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,1),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'机构'),COLORWHITE;
操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,1),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,1), COLORRED;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,1),COLORGREEN;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,1),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,2.7,3.3),'大户'),COLORWHITE;
操盘2:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,1), COLORRED;
减仓2:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,1), COLORRED;
反弹2:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,1),COLORGREEN;
寻底2:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,1),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,1.2,1.8),'中户'),COLORWHITE;
操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,1),COLORRED;
减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1,1), COLORRED;
反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,1),COLORGREEN;
寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1,1),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,-0.3,0.3),'散户'),COLORWHITE;                                                                     MACD 通达信 辅图(自用)
DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAEA1:=EMA(DIFIF1,9);
MACD1:=2*(DIFIF1-DEAEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.1,0),COLORGREEN;
STICKLINE(MACD1DIF:DIFIF1;
DEA:DEAEA1;
MACD:MACD1,NODRAW,COLORMAGENTA;
A1:=BARSLAST(REF(CROSS(DIFIF1,DEA),1));
A2:=BARSLAST(REF(CROSS(DEA,DIFIF1),1));
零轴线:0,COLORWHITE;
DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1,1);
DRAWICON(CROSS(DEAEA1,DIFIF1),DIFIF1,2);
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFIF1>REF(DIFIF1,A1+1) AND CROSS(DIFIF1,DEA);
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORYELLOW,LINETHICK2;
顶背离:=REF(CLOSE,A2+1)DIFIF1 AND CROSS(DEA,DIFIF1);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK2;       自动画线;MACD 通达信 副图DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
水下金叉:=CROSS(DIFF,DEA) AND DIFF<0;
STICKLINE(水下金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(水下金叉,-0.2,' 水下金叉水上渔'),COLORWHITE;
水上金叉:=CROSS(DIFF,DEA) AND DIFF>0;
STICKLINE(水上金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(水上金叉,0.15,' 水上金叉鱼満仓'),COLORWHITE;
金叉爬坡:=CROSS(DIFF,DEA) AND DIFF>=-0.1 AND DIFF<0.1;
STICKLINE(金叉爬坡,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(金叉爬坡,0.22,'金叉爬坡金満钵'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND COUNT(JCCOUNT>=2,10)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.25,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,0.10,' 底背离要捕鱼'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;

烽火变盘 通达信 辅图
V1:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(V1*8)*100;
A3: COS(V1*8)*100;
X1: 0;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,1,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,4,0),COLOR0099FF;
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-140,4);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'->买点'),COLORRED;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,1,0),COLORRED;
谨慎观望: STICKLINE(VAR6REF(VAR8,1) AND VAR6>0,VAR6,VAR8,1,0),COLOR00FF00;
果断持币: STICKLINE(VAR6

展翅:涨停先锋 通达信 辅图

DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),(LOW * 0.99),'Ψ'),LINETHICK3,COLORF00FF0;

展翅:涨停提示 通达信 辅图

ZDF:=(C-REF(C,1))/REF(C,1)*100; STICKLINE(ZDF>9.8,O,C,3,0),COLOR0000FF; STICKLINE(ZDF<-9.8,O,C,3,0),COLORFF0000;

展翅:通达信股票公式    副图 ­

VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;­

VAR2:=SMA(VAR1,3,1);­

VAR3:=SMA(VAR2,3,1);­

VAR4:=3*VAR2-2*VAR3;­

VAR5:=LLV(LOW,5);­

VAR6:=HHV(HIGH,5);­

VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;­

VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);­

VAR9:=3*VAR7-2*VAR8;­

VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);­

VARB:=POW(MA(LOW,5),2)+MA(LOW,5);­

VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);­

VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;­

VARE:=SMA(VARD,3,1)*1.5-100;­

VARF:=SMA(VARE,3,1);­

VAR10:=3*VARE-2*VARF;­

VAR11:=(HIGH+LOW+CLOSE*2)/4;­

VAR12:=EMA(VAR11,13);­

VAR13:=STD(VAR11,13);­

VAR14:=(VAR11-VAR12)*100/VAR13;­

VAR15:=EMA(VAR14,5);­

VAR17:=EMA(VAR15,13)+200-100;­

VAR18:=EMA(VAR17,10);­

VAR19:=3*VAR17-2*VAR18;­

VAR1A:=VAR2+VAR7+VARE+VAR17;­

VAR1B:=VAR3+VAR8+VARF+VAR18;­

VAR1C:=VAR4+VAR9+VAR10+VAR19;­

VAR1D:=(HIGH+LOW+CLOSE)/3;­

VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));­

VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;­

VAR23:=EMA(VAR22,24);­

VAR24:=STD(VAR22,24);­

VAR25:=(VAR22-VAR23)/VAR24*100;­

VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));­

VAR27:=EMA(VAR25,5);­

VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;­

VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2;­

VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;­

VAR2D:=EMA(VAR2C,7);­

VAR2E:=(VAR2A+VAR2C)/2/1.1; ­

超短:EMA(VAR2E,3),COLORRED ;­

短线:EMA(超短,5),COLORWHITE;­

趋势线:EMA((VAR2B+VAR2D)/2,2) ,COLORYELLOW;­

DRAWICON(CROSS(趋势线,0),0,1);­

DRAWICON(CROSS(100,超短),100,2);­

DRAWTEXT(趋势线>REF(趋势线,1)AND REF(趋势线,1)

买入:CROSS(超短,短线);­

DRAWTEXT(买入,超短,'←买入'),COLORYELLOW; ­

加仓:CROSS(超短,趋势线);­

DRAWTEXT(加仓,趋势线,'←加仓'),COLORYELLOW; ­

★美丽天鹅:急速拉升器 通达信 辅图

RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K:SMA(RSV,3,1),LINETHICK2;
D:SMA(K,3,1),LINETHICK2;
J:3*K-2*D,LINETHICK2,COLORRED;
急拉:83,COLORWHITE,LINETHICK3;
中轨:50,CIRCLEDOT,COLOR000FFF;
抄底:-1,LINETHICK3,COLORGREEN;

★MSD指标----副图

N:=34; K:=3;
个股:EMA(100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),K);
大盘:EMA(100*(INDEXC-LLV(INDEXL,N))/(HHV(INDEXH,N)-LLV(INDEXL,N)),K);
拉升线:80;
试庄线:20;
强弱线:50;

超然:收红包(改版) 通达信 辅图
【说明:[原版 凯恩斯]  用法:底部出现红包关注,趋势线冲过底部买进,适合波段操作】REFLINE: 0, 100,180,230;
{收红包}
{副图}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
STICKLINE((阶段底部 >= 0),0,阶段底部,0.3,1),LINETHICK2,COLORCC6600;
STICKLINE((阶段底部 < 0),0,阶段底部,0.8,1),LINETHICK6,COLORRED;
趋势线:LLV(阶段底部,1),COLORCYAN;
STICKLINE((趋势线 >230 ),250,趋势线,0.8,1),LINETHICK6,COLORGREEN;
STICKLINE((CROSS(趋势线 ,120 ) ),趋势线,120,0.8,1),LINETHICK6,COLORYELLOW;
230,COLORFFFFFF;
100;
STICKLINE((趋势线 >180 ),180,180,0.8,1),LINETHICK6,COLORGRAY;


 

★新军: 波段介入 通达信 辅图

顶:80,COLORFFA500;
大顶:100,COLORBLUE;
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
VAR2:=SMA(VAR1,10,1);
慢速:SMA(VAR2,5,1),COLORRED;
RSV:= ((HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100)-70;
RSV1:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
FATK:=SMA(RSV1,3,1);
形态:SMA(FATK,3,1),COLORBB24DB;
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:=SMA(VARA,3,1);
VARC:=SMA(VARB,3,1);
加速: EMA(3*VARB-2*VARC,3),COLORYELLOW;
底:6,COLORMAGENTA;
大底:-6,COLOR007500,LINETHICK2;
VAR11:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR22:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
买入:=VAR11 AND VAR22,STICK,LINETHICK2,COLORRED;
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;
卖出:=CROSS(80,VAR4),STICK,LINETHICK2,COLORGREEN;
{波段介入点}
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
波段介入点:IF(A2<19,19,0)COLORWHITE;
中位线:50,COLORGREEN;

海風:量能(逃顶)通达信 辅图

 

部分内容设定了隐藏,需回复不毕等第二天的信号出现,你就可以判断出来,­

而且,在买入加仓的信号也精确显示,­

对打击主力踪迹,确保散户收益的好指标!­

巨量有下部(负交易量)说名主力,一边拉升,一边出逃­

,黄色成交量,且中间为红色蜡烛芯的,说明主力控盘,­

出现兰色或粉红色的蜡烛色!情况就不妙!­

根据股票的趋势线做分析是否出逃!­

操作口诀:­

选好股,挑好庄;等大势,看起航。­

跟上了,看着庄;他撤退,我清仓。­

破趋势,急离场;等着跌,莫手痒。­

白色烛,红芯长,庄家找底在振荡,俺也伺机建点仓。­

  ­

黄色烛,红芯长;庄家进货强,俺也进货等起航。­

粉色烛,红芯长,庄家高抛低吸操作忙,俺也去逐浪。­

蓝色烛,红芯短,巨量绿尾长,庄家撤退,俺也清仓。­

巨量绿,蓝烛长,趋势破,急离场;等着跌,莫手痒。­

­VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((VOL > 0),VOL,0,4,1),colorFFFFFF;
STICKLINE((买卖差 > 0),0,买卖差,4,0),color0000FF;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,color33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));


VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,4,1),color0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,4,1),color00FF00;
STICKLINE((鬼力 > 0),鬼力,0,4,0),colorFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),color00FFFF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,4,0),colorFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,4,0),colorFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,4,0),colorFF00FF;
相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);


★股海舵手-导航:经典版KDJ 通达信 辅图

(参数:N 0 100 99   M1 0 100 3   M2 0 100 1   N1 0 100 99  )

 

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100; K:SMA(RSV,M1,1); D:SMA(K,M2,1); J:3*K-2*D; 0; 50; 100; WR1:100*(HHV(HIGH,N)-

CLOSE)/(HHV(HIGH,N)-LLV(LOW,N)); WR2:100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));


 

海风 :专吸庄血 通达信 辅图(参数:N 1.00 100.00 10.00)

VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)- 
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1; 
VAR2:8,COLORGREEN,LINETHICK0; 
增强体力: IF(CROSS(VAR1,VAR2),80,0),STICK,LINETHICK2; 
专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2; 
DRAWTEXT(CROSS(VAR1,VAR2),80,'准备买入'); 
VARO5:=LLV(LOW,27); 
VARO6:=HHV(HIGH,34); 
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25; 
建仓区: IF((VARO7<10),80,100) ,LINETHICK1; 
0, LINETHICK1;

 

愚公杀庄 通达信 副图

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
{(趋势>80);}
DRAWICON(CROSS(趋势,0),0,1);
{((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;}
大庄建仓区:=0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'准备数钱\'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,3,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'明天买进\'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,3,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清仓\'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'小心\'),COLOR00FF00;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
五指山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(五指山>0,0 ,五指山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线:趋势,COLORFF00FF;

VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
分水岭:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17VAR18:=MA(趋势线,8);
{IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;}
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'全仓买进\'),COLORYELLOW;

 

变色KDJ  通达信 辅图

VAR1:=(H+L+O+C*2)/5;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,23);
VAR4:=EMA(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
K:(EMA(VARA,23)+100)/2-3,COLOR00FFFF,LINETHICK2;
D:SMA(K,5,1),COLORFFFF00,LINETHICK2;
J:4*K-3*D,COLORFF00FF,LINETHICK2;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
IF(JDRAWICON(FILTER(J>REF(J,1)AND JAND JREF(VAR4,1)
AND K>=REF(K,1)AND J<40
OR CROSS(J,K)AND CROSS(J,D)
AND J<40 OR J>REF(J,1)AND J<-20,7), J*0.8,1);
DRAWICON(FILTER(J<=REF(J,1) AND J>80,8), J*1.2,2);

100 COLORBROWN LINETHICK2;
00 COLORBROWN LINETHICK1;

 

Y1:=100*VOL/FINANCE(7);
DRAWICON(Y1>0.16,K*1.04,10);
DRAWICON(CROSS(D,K),D+0.6,15),COLORGREEN;
DRAWICON(CROSS(K,D),D-0.3,9),COLORYELLOW;